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Introduction and background information 
 

Trimble Business Centre (TBC) allows users to import and process 12d data. These following 

workflows show users how to import 12da files containing:  

• Super Strings – with pipes, attributes, and Vertex text 

• Super Alignments – with pipe data and attributes 

• TIN’s  

• Trimesh objects   

• General Detail surveys 

The 12da data can be imported into TBC using a range of different settings which allow the user to 

choose to import features in different ways. The following workflows provide some examples of 

these different data types and how TBC handles them. 

At the end of a 12da file being imported a box will appear that contains information on any errors or 

warnings that may have occurred during import. It is important to review these to understand if any 

data was not imported.  

Using the 12da import settings the data can be given a layer prefix and a layer group at the time of 

import. These options are located at the top of the settings in the import pane and allow users to 

better manage and identify newly imported data. After import, the data layers can also be easily 

regrouped and renamed using the ANZ toolbox function “Regroup/Rename Layer”. Users can select 

data in the plan view, using advanced select or in the project explorer, then the selected object 

layers can be grouped or renamed with a prefix or suffix. The tool also displays a list of all the 

current layers from which they can be easily selected.  

We strongly recommend reading the help page for Advanced 12D support for better understanding. 

 

Note: It is important to note that to access the extra settings you must go through the Import pane 

and not use drag and drop. The previously used settings in the import pane are also what you get 

when using the drag and drop method, and the import pane will hold the last used settings until 

changed again. 

https://www.trimblebusinesscenter.com.au/docs/12d_Import_Export.pdf
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1.Setting up a Project in TBC 

 

TBC Template Setup  
Before importing any data, it is important to get your project template setup. 

Launch a new project  
In Trimble Business Centre, do either of the following: 

1. On the Start Page, click the New Project button. 

2. In the TBC ribbon, select File > New. 

The New Project window will display. 

 

Select Metric template or your own default template and click OK. The Plan View will then 

display.  

 

Change the Project Settings 
1. In the top left corner of the Quick Access toolbar select project settings.  

 

 
 

2. Fill out any of the General Information if necessary or skip this section.  
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3. If using a published Coordinate System select Coordinate System, then click Change 

and select from the list. 

 
4. If using a site calibration file drag and drop into the Plan View.  

A basic template has now been set up in TBC and the software is now ready to import data.  
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2.Colour.4d files  
 

Before importing any 12da files it is possible to setup the same colour pallet that was used in 12d if 

you have the colour.4d file from 12d. To import a colour .4d file the drag and drop method can be 

used.  

1. In the windows file explorer locate the .4d colour file you wish to import.  

2. Select the file and drag and drop the file in the Plan view in your TBC project. The imported 

file should display in the imported files folder in the Project Explorer.  

 

Note: To display the project explorer navigate to Home > Data > Project Explorer.  

 

If you do not have the colour file used to create the data in 12d then TBC will assign the closest 

system colour. User-defined colours are assigned the By layer colour and reported as warnings in 

the Import Report.  
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3.Importing Drainage Strings 
 

This data is imported as manholes and pipes with the naming conventions, models, attributes, and 

location data taken directly from the 12da file. Pipes are set to Calculated “End type” by default but 

can be edited in TBC after import. 

To import drainage pipes and manholes: 

1. Start by opening the import window. Navigate to Home > Data Exchange > Import.  

2. In the import window click the  icon. The Import Folder window should display.  

3. Navigate to the folder containing the drainage data you wish to import. Click OK.  

4. In the import window select the 12da file. Change the settings if required. Click Import.  

 

The Pipes and manholes should display in the Plan View. To view the data in 3D view, open a new 3D 

view by clicking the  icon in the quick access toolbar or navigate to Home > View > 3D View.  
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The image below displays an example of pipes and manholes that have been imported into TBC 

using the process described above.   

 

The 12D importer automatically imports both the pit and pipe objects into the Material and Site 

Improvement (MSI) Manager. The MSI Manager is where these objects are defined and can also be 

edited. To access the MSI manager:  

1. Right click on the Utility Networks dropdown in the project explorer.  

2. Select Material and Site Improvement Manager.  

 

The MSI Manager should now be displayed and the defined pipe and pit objects that were created 

on import can be explored by expanding the Site Improvements list. An example is shown on the 

following page.  

 

 



 

9 
 

 

In the example above you can see all the information defining the Pit objects that was imported and 

the parameters such as Length, Width, Thickness, Colour and Name can be edited here.  

The properties of individual Pits or Pipes can be displayed by:   

1. Selecting the feature in the Plan View or in the Project Explorer 

2. Then pressing F11 or right clicking in the Plan View and selecting Properties.  

In the Properties tab information such as the Site Improvement Model, Layer, Colour and Location 

(Easting, Northing and Elevation) can be explored and edited.  

Using “Create lines for Drainage Pipes” setting 
When importing Drainage pipes and pits follow the import process described above but change the 

import setting Create lines for drainage points to Yes. A line string is created between the manholes 

applying the pipe invert level at the centre of manholes and these strings are placed on a layer of the 

same name with _lines as a suffix. These line strings are handy for use in machines or survey 

controllers.  

Note: A line string is created between the manholes applying the pipe invert level at the centre of 

manholes as the line created will go from centre to centre, not the inside of pit wall. 
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Before changing Create lines for drainage points to Yes.  

 

After changing Create lines for drainage points to Yes. 
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4.Importing Super Strings with Pipes, Attributes and Vertex Text 
 

Super Strings are imported into TBC as line strings. In 12d, super strings can have attributes 

associated to the entire line and attributes associated with separate vertices. The Settings in the TBC 

import window allow users to choose whether they want to import the attribute data for both the 

line string and vertices associated with a line. Super strings can also have pipe data associated to 

them. To import super strings with both vertex and line attributes and pipe data:  

1. Start by opening the import window. Navigate to Home > Data Exchange > Import.  

2. In the import window click the  icon. The Import Folder window should display.  

3. Navigate to the folder containing the data you wish to import. Click OK.  

4. Select the 12da file that contains the Super Strings.  

5. In the settings change the Create SuperStrings points setting to Yes and change the Pipes 

from SuperString Pipes to Yes. As shown below. 

6. To create text from the vertex and segment text change the Create Vertex text setting to Yes 

and give it a height and layer suffix. 

 

Notes:  

By changing the Create SuperStrings points setting to Yes, points are created at the vertices with the 

attribute data that was defined in 12d. 

 By changing Pipes from SuperString Pipes to Yes, a pipe object is created from the pipe data and 

placed on a layer of the same name with _pipes as a suffix. 

By changing Create vertex text to Yes, text is created on screen at the height set and using the layer 

name from which the data came with a suffix set by the user. If this is set to No, then the data is still 

imported and can be seen in the properties pane under “12d Text Data”. 
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Imported Super String using default settings.  

 

Imported Super String with changed settings.  
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5.Importing Super Alignments  
 

Super Alignments are imported as a segment-based horizontal alignment and as a PI based vertical 

alignment. In 12d they can have pipe data and attributes associated to them and by changing the 

Pipes from SuperString Pipes setting to yes on import it will create a Pipe model along the 

alignment if it is defined in the 12da file.  The alignment attributes are also imported if available and 

if an alignment of the same name exists in the TBC project the new one being imported will be given 

a suffix of the users choice. 

To import a basic Super Alignment:  

1. Open the import window, navigate to Home > Data Exchange > Import.  

2. In the import window click the  icon. The Import Folder window should display.  

3. Navigate to the folder containing the Super Alignment data you wish to import. Click OK.  

4. In the import window select the 12da file. Change the Pipes from Superstring Pipes setting to 

No.  

5. Change the Duplicate alignment suffix name if required and Click Import. 

 

 

 

Note: If a super alignment has a spiral that is not supported you will get a message in the warnings 

“A spiral on segment ‘no.’ with unsupported geometry was replaced on alignment: ‘name’ with a 

straight”. 
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The image below shows an example of an imported Super Alignment without pipe data.  

 

To import a Super Alignment with Pipe Data, follow the steps described above, however change the 

Pipes from SuperString Pipes setting to Yes.  
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By changing this setting, a Pipe object is created along the alignment as defined in the 12da file and 

placed on a layer of the same name with _pipes as a suffix. The image below displays the same data 

as the alignment used in the above image with the Pipes from SuperString Pipes setting changed to 

Yes. 
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6.Importing TIN’s 
 

TIN data is imported as a 3D surface with internal data, meaning the data is embedded in the surface 

on import and cannot be edited in TBC. To import a TIN:  

1. Open the import window, navigate to Home > Data Exchange > Import.  

2. In the import window click the  icon. The Import Folder window should display.  

3. Navigate to the folder containing the TIN data you wish to import. Click OK.  

4. In the import window select the 12da file. The default settings are appropriate. Click Import.  

Note: The “ignore small triangles” setting is set to No by default. It Stops the import of tiny triangles 

less than 1mm2 from 12d that can cause problems in the surface and not import properly. You may 

need to test the import set to yes if the surface does not come in correctly to start with. 

The imported Surface may have flags displaying and maybe holes. This is possibly due to small errors 

from vertices being on top of each other or very close to vertical. Prior to importing your surface file, 

you can go to the Project Settings and change the “Duplicate point tolerance” setting to 0.001mm. 

(Only available in V5.40 and beyond) or we have also made this same option available in the 12da 

import pane called “Duplicate surface point tolerance”. You can use this setting here to be the 

default for every 12da file imported while leaving the “Project” setting at a different level.  

Note: If for some reason the surface comes in empty try changing the setting back to 0.1mm. 

Option to add a surface prefix on import. 

 

12d import pane option for duplicate points. 

  

Project Settings menu for duplicate points. 
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This is what your surface may look like with using the 0.1mm setting. 

 

Review the flags by clicking on the little red flag at the bottom of the screen. The image below shows 

the surface when imported with the “Duplicate surface point tolerance” set to 0.001mm.  

          

Note: It is recommended that when exporting a surface from 12d that you uncheck the “Output full 

tin” option as this can cause errors in the surface edges within TBC. 
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If importing files exported from 12d V15 then please check that the export settings used are as 

shown in the image below. By default, the 12d export panel is set to export surfaces as hexadecimal 

which can now be read into TBC but not Trimble Access. 

 

7.Importing Super Tins 
 

This data will be imported and turned into a “Composite Surface”. If the Super tin contains tins using 

the “Remove” mode, they will be ignored and flagged at import. 

Note: If the composite surface does not form properly try recreating the surfaces that are being 

used in the composite surface within TBC using the original surfaces as the members for each 

surface. 

8.Importing Trimesh 
 

12d Trimesh data is imported as 3D BIM objects.  

1. Ensure the colour .4d file has been imported (see p.g. 6) if you want to map them the same as 

it was in 12d. Open the import window. Navigate to Home > Data Exchange > Import.  

2. In the import window click the  icon. The Import Folder window should display.  

3. Navigate to the folder containing the Trimesh data you wish to import. Click OK. 

4. Select the 12da file and click Import.   
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An example of Trimesh data imported into TBC is displayed below.  

 

 

Note: Upon importing 12da files with Trimesh data TBC will (from V5.90) populate the BIM Data 

section in the Project explorer with these objects.  
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9.Detail Survey Import 
 

This is an example of importing a detail survey from a 12da file. To allow the features such as 

colours, line styles and symbols to map correctly in TBC the associated colour 4d file and feature 

definition library in FXL format are required. To import a 12da file with general detail survey into 

TBC:  

1. Start by dragging and dropping the associated colour 4d file in the plan view. If this step is not 

followed TBC may not recognise the colours of certain features created in 12d.  

2. Drag and drop the appropriate FXL file (Feature Definition Library) into the plan view. This 

allows the symbols, line styles and layering to exist in TBC.  

3. Open the Import window, Home > Data Exchange > Import. 

4. In the settings change String Point Type to “Point”.  

5. Click Import.   

Note: TBC will not process CAD points therefore ensure the string point type is changed in the 

import pane if you want to get symbols.  

If the 12da file is correctly matched to the colour file and FXL then when the data comes in as 

described above, it will adopt the incoming colours and line styles automatically but will require the 

processing of the feature codes for the points to be assigned symbols.  

To process feature codes: 

1. Navigate to Survey > Field Data > Process Feature 

Codes or GIS > Feature Definition > Process 

Feature Codes.  

2. In the Process Feature Codes tab tick the box 

containing the imported 12da file.    

3. Click Process Source(s). 
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In the below image is an example of a TMR detail survey brought in from a 12da file using the above 

process. It now displays as you would see it in 12d. 

 

10.Image Import 
 

Images attached to points and lines in a 12da file will be imported and shown in the “Media Files” 

folder in the project explorer. Images attached to lines in 12d will have points created for them to 

attach to in TBC. Plan Images shall be drawn in the plan view of TBC on the same layer as the point 

or line they came from. 

Note: The Image files need to be in the same folder as the 12da file they are used in when importing 

into TBC for them to be used. 

Below shows point 1001 with a “Plan” image and point 1000 with an “attached” image file. 

 


