
 

 

 

 

  

TBC ADAC WORKFLOW 

 

V1.3 October 2024. 



 

2 
 

Contents 
Introduction and background information ............................................................................................. 3 

1.Setting up a Project in TBC ................................................................................................................... 4 

TBC Template Setup ............................................................................................................................ 4 

Launch a new project .......................................................................................................................... 4 

Change the Project Settings ................................................................................................................ 4 

Load the feature definition file (FXL) into TBC .................................................................................... 6 

Customise feature definition file (FXL) ............................................................................................... 7 

2. Processing the Data ............................................................................................................................ 7 

Importing the data .............................................................................................................................. 7 

Project Explorer .................................................................................................................................. 8 

Processing Feature Codes ................................................................................................................... 9 

3.Editing using CAD and other commands ........................................................................................... 11 

Editing line and polygon geometry ................................................................................................... 11 

Using CAD Grips and Smart Snaps ................................................................................................ 12 

Using the Editing tool .................................................................................................................... 13 

Editing Attribute Data ....................................................................................................................... 16 

Creating a missing point feature ....................................................................................................... 18 

Using the TBC background map ........................................................................................................ 21 

4.ANZ Toolbox customization and additional commands .................................................................... 23 

Set Sewerage Connection Attribute Command ................................................................................ 23 

ADAC Settings V5.01 or V4.2 ............................................................................................................. 26 

6.Validate and Export an ADAC XML from TBC ..................................................................................... 27 

7.Importing ADAC XML into TBC ........................................................................................................... 29 

8.Annotating drawings with Attribute values ....................................................................................... 30 

9.Code names and Features List ........................................................................................................... 31 

Standard ADAC Schema .................................................................................................................... 31 

Adding Supplementary features ....................................................................................................... 31 

Standard Line Control Codes used in ADAC FXL’s ............................................................................. 31 

Appendix ........................................................................................................................................... 32 

 

 

 

  



 

3 
 

Introduction and background information 
 

This manual has been created to assist utilising Trimble Business Center (TBC) software to create a 
new ADAC project, import data, process and Export ADAC XML. 
 
This workflow gives the user a general understanding on how to use an FXL, CAD commands and the 
ADAC setup tool to create, edit and then export an ADAC xml. 
  
Users of this manual are urged to be familiar with the basics of processing feature codes in Trimble 

Business Center(https://geospatial.trimble.com/trimble-business-center-tutorials), publications and 

standards of Asset Design and As Constructed (ADAC) data specification and transport format (XML) 

available from the IPWEA website: https://www.ipweaq.com/faq-s 

ADAC is an open source format for the standardisation of asset design and as constructed data. 

Covering a wide selection of asset categories, consisting of: 

  

  

https://geospatial.trimble.com/trimble-business-center-tutorials
https://www.ipweaq.com/faq-s
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1.Setting up a Project in TBC 

TBC Template Setup  

Before importing any data, it is important to get your project template setup. 

Launch a new project  

In Trimble Business Centre, do either of the following: 

1. On the Start Page, click the New Project button. 

2. In the TBC ribbon, select File > New. 

The New Project window will display. 

 

Select Metric template and click OK. 

The Plan View will then display.  

 

Change the Project Settings 
1. In the top left corner of the Quick Access toolbar select project settings.  

 

 
 

2. Fill out any of the General Information if necessary or skip this section.  
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3. Select Coordinate System then click Change.  

 

4. Select the specific coordinate system associated with the job. For this workflow 

we are using GDA94 Zone 56. Click Next.  
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5. Select the Geoid Model (AUSGeoid09 for this example), the Geoid quality and the 

name of the vertical datum (AHD). Then click Finish.  

Note: You can change more project settings if you wish, but for this workflow, we are mainly 

concerned with the coordinate system and units.  

Load the feature definition file (FXL) into TBC 

To load the FXL into TBC you can do either of the following:  

1. In the navigation pane in the Project Settings dialog, select Feature Code 
Processing.  

Click the Browse button  located to the right of the Feature definition file 
field.  

In the Open dialog, browse to where the ADAC_TBC_V?.fxl is located and click 
Open.  

 

2. Alternatively, drag and drop the FXL into the plan view.  
 

The project is now set up and ready to import in the ADAC data.  

Note: The ADAC FXL files can be found C:\Program Files\Sitech 

Construction Systems and in the ANZToolbox folder for your TBC version. 
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Customise feature definition file (FXL) 

It is possible to add extra ‘Supplementary’ features into your FXL file to suit the work being 

undertaken. These can be point, polyline, or polygon features. The key is to ensure they're created 

under the 'supplementary' category. An easy way to do this is by duplicating an existing feature, 

then customizing it with any additional attributes that fit your specific needs. 

It's also worth noting that the ‘class’ attribute for a supplementary feature is tied to the feature's 

name. This means if you have a separate 'class' attribute in your attributes list, it will be bypassed 

due to the way the code is structured. 

2. Processing the Data  

Importing the data  

The next step is to import in the survey data you wish to use to create the ADAC xml.  

1. Navigate to Home > Data Exchange > Import.  

2. The Import pane will then pop up. Use the  icon to navigate to the folder that 

contains the file you want to import. Click OK.  

3. Select the file you wish to import from the list. Change the settings if required. 

Then click Import. 

The image below shows the unprocessed points we have imported and will be using for this 

workflow.  
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Project Explorer 

Before you process the feature codes in your project, you can view the codes and their assigned 
values, and make changes if necessary.  

 
1. In the TBC ribbon, select Home > Data > Project Explorer. The Project Explorer 

pane should display.  
2. In the Project Explorer pane, expand the Points node. Then double-click the point 

you wish to view. (Point 1 in this example).   
 
The Properties pane displays showing properties for point 1. The feature code assigned to the point 

displays in the Point Information section.  

 

Click the Browse button  in the Feature code field to view more information about the feature 
code in the Feature Code Editor dialog. 

 

 
 
This dialog allows you to remove a feature codes, select a different feature code, add a feature code, 

and/or change attribute values. 
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Processing Feature Codes 
1. The next step is to process the feature codes.  

Navigate to the GIS > Feature Definition > Process 

Feature Codes.  

2. Select the point source (demo.xml for this example) 

you want to process for and then click Process 

Source(s). By processing feature codes TBC uses the 

coding and attribute information to string together 

points with line codes, colour the linestrings, layer 

features, give points symbols and process attribute 

information. The image below shows the points after 

processing.  
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Comparing the properties of point 59 before processing to the properties of point 59 after 

processing.  

 

As displayed above. After Processing Feature codes, point 59 now has ADAC standard attributes in 

the properties tab as well as having a defined feature name and corrected layer.   

  

Before Processing  After Processing 
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3.Editing using CAD and other commands  

It is rare for there not to be any errors in data after processing. This workflow shows how to use CAD 

commands and other functions to correct and edit some errors users may come across.  

Editing line and polygon geometry  

In the example the lot in the far-left corner has an error. The bottom left corner of the lot is meant 

to be at an angle of 90 degrees. This can be corrected multiple different ways, for this example we 

will use two different methods one using CAD grips and smart snaps and the other method using the 

editing tool.  
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Using CAD Grips and Smart Snaps 
1. Start by clicking on the lot selecting the polygon.  

 

Note: you can right click and select edit to input the coordinate of the bottom left hand 

corner.  

2. In the bottom right corner of the quick access toolbar click on  to open the 

Running Snap Mode Options. Ensure Perpendicular Point is checked and click 

OK. This ensures the bottom left corner will snap to a perpendicular when using 

the CAD grips.  
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3. Click and hold the yellow square in the bottom left corner. You can use the 

mouse to place the corner anywhere on the plan view. However, we want the 

point to be perpendicular to the other points. While holding, place the cursor 

near the bottom right corner of the lot. The perpendicular snap symbol should 

pop up (Circled below). Once the perpendicular snap symbol pops up, while 

holding the snap still place the cursor near the perpendicular symbol and release 

the mouse. The bottom left corner should snap to the perpendicular point.  

 

4. You can choose to move the lot corner point to the new corner of the polygon. 

However, it is not required as you will not be exporting the point with the ADAC 

xml.  

To move the point, navigate to CAD > Edit > Move.  

 

Using the Editing tool  
1. Start by clicking on the lot selecting the polygon.  

 

 
 

2. Left click in the plan view and select Edit.  

3. In the Edit Line string click in the Current segment box and ensure it is 

highlighted.  

4. In the plan view select the line string that has the arrow pointing to the point 

which you want to edit. Notice the arrow circled in red pointing towards the 

point we are going to edit.  
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5. Now the line string is selected highlight the coordinates box.  

6. In the plan view right click and select the Bearing Bearing command. 

Note: The Bearing Bearing command calculates the coordinates of the intersection point of two 

bearings. 
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7. Select the North West corner as the reference point 1. Select the North East 

corner to calculate bearing 1. This calculates the bearing from the North West 

corner to the North East corner to be 100d 28’ 51.7”. See below.  

 

8. Click in the bearing 1 box and after the bearing type 

+90 and press tab. This Adds 90 degrees to the 

bearing. 

9. Select the South East corner as Reference point 2. 

Select the North East corner to calculate Bearing 2. 

Minus 90 degrees from Bearing 2.  

10. Click OK. 

11. The new coordinates have now been calculated. Input an elevation if required 

then click save.  
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Editing Attribute Data 

In post processing TBC allows the user to edit attribute data. Errors in attributes can be adjusted and 

unknown attributes in the field can be input in the office. An example of how this may be carried out 

is demonstrated below.  

The image below shows two sewer circle manhole points and three pipe (non-pressure) strings. Let 

us bring up a feature spreadsheet to have a look at the attributes associated with these features.  

 

1. To open a feature spreadsheet, navigate to GIS > Feature Definition > Process 

Feature Codes drop down > Feature.  A blank feature spreadsheet should 

display.  

The Select Feature drop down shows a list of all the feature names and the number of each specific 

features in your project. The image below shows the Pipe (non-pressure) with a feature count of 

three.  

2. To display attribute information associated with the pipe tick the check box on 

the left-hand side and then click Apply.  

 

Note: you can check multiple boxes to display attribute information for multiple features at once.  
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A list with the attribute information should then display.  

 

Filters can be used to display features with specific attribute values. By clicking the  icon a range 

of filter options are displayed, including: 

• All – displays all attributes of the selected feature 

(default). 

• Custom – allows the creation of custom filters using 

functions such as equals to, less than, starts with etc.  

• Blanks – displays all features that have no attribute 

value for a specific attribute.  

• NonBlanks - displays all features that have an attribute 

value for a specific attribute.  

Once a satisfactory filter has been selected, attribute editing can begin. For this example, the “all” 

filter is acceptable.  

Looking at the feature spreadsheet of the example above there are some errors that need to be 

corrected. The diameter and lining of the pipe at the bottom of the list should match the attributes 

of the pipe above it as they have the same line number but are split into two different strings 

because a manhole separates them.  

 

These attributes can be edited two different ways.  

1. Using the Feature Spreadsheet  

2. In the Properties window  

The feature spreadsheet will be used for this example.  

Simply, click on the attribute value you wish to edit and either choose from the list or input the value 

using your keyboard and press enter. 
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Creating a missing point feature 

In the field features can be missed during a pickup survey. TBC allows the user to easily create 

features manually during post processing. This workflow shows how to create points in TBC.  

In the example, there is a manhole missing in between two of the pipe strings as seen below.  

 

To create a point in between the two pipes.  

1. Start by navigating to CAD > Points > Create Point.  

2. The create point menu should then display. Fill in the data 

fields i.e. Point ID, Layer, Feature Code and attributes. For this 

example, the feature code of SCMH (Sewer Circ Manhole) is 

used.  

Note: If you are creating strings in TBC make sure you give the 

code a string number for example giving string points a code of 

SNP1 all the points with this code will be strung together when 

processing feature codes.   

 

 

 

 

 

 

 

 

3. The next step is to give the point some coordinates. Click in the Easting box.  
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4. With the cursor in the plan view Right Click. In the drop-down list select Middle 

of Point to Point.  

 

 

5. Select the end points of both strings (which end point you select first does not 

matter). 
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Note: By using the middle of the point to point function the manhole 

point is placed at the invert level between the two pipes. See the image 

to the right, by using the Middle of Point to Point function the Easting, 

Northing and Elevation were calculated.  

6. Once the point has the correct coordinates and 

attribute data, click Add.  

The point that was just created should appear in the plan view.  

Note: if the point did not appear in the plan view ensure the correct layer 

is turned on.  

7. The final step is to process the feature codes again 

(described in detail on p.g. 9). Ensure the Keyed in 

Block check box is ticked before processing the codes. 

Note: Every time a new point is created in TBC and that point is required 

to be exported in the ADAC XML, ensure the Keyed in block feature codes 

are processed. This guarantees points are strung together correctly, the 

feature data is correctly displayed in the software and the data associated 

with that point will be correctly exported in the ADAC XML.  
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Using the TBC background map 

TBC allows users to toggle on and off a background map within the plan view (as seen below). The 

background map is a good tool to use to check if the project is in the right general location. To use 

the background map feature, TBC requires the user to log in with their Trimble ID.  

 

The following workflow will show users how to log into TBC with their Trimble ID and access the 

background map.  

1. Access the Start Page. Navigate to Support > 

Start-Up > Start Page.  

2. In the Start Page click Log In located in the 

top right corner.  

3. Fill in your credentials if you have a Trimble 

ID or create a new Trimble ID for free in the 

same window. Click Sign In.  

4. In the Plan View toggle, the background map 

by clicking the  button on the bottom 

quick access toolbar.  
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You can change the background map from a street view to satellite image. To do so navigate to the 

project settings.  

1. Click  button in the quick access toolbar. The Project Settings will then 

display.   

2. Navigate to View > Plan View. Under the background map tab, you can change 

the type from ‘Street’ view to ‘Satellite’ view.  

 

 

 

 

  

Trimble Maps - Satellite Trimble Map - Street 
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4.ANZ Toolbox customization and additional commands 

ANZ Toolbox has been created by our SITECH team and features commands that are required to 

setup an ADAC project and assist with ADAC data preparation. 

The following workflows display how some of the tools in the ANZ Toolbox can be used to create 

ADAC files and require the ANZ Toolbox Module.  

Set Sewerage Connection Attribute Command  

The Set Sewerage Connection Attributes command automatically calculates distances required to be 

measured between a house connection, sewerage pipes and the cadastral boundaries. Choose either 

V4.2 or V5.01 version depending on your required data output. 

1. To use the command, navigate to ANZ 

Toolbox > ADAC > Set Sewerage Connection 

Attributes. The Set Sewerage Connection 

window should then display.  

2. Select the House Connection geometry 

representing the property sewerage 

connection in Plan view or 3d view.  

3. Select the Sewer line the house connection 

runs into.  

4. Select the Down Stream Manhole along the 

sewer line from the house connection.  

5. Select the Lot/Cadastral Boundary.  

An example is shown on the next page.  
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6. Check the annotate box to display line strings with the associated connection 

lengths in plan view.  

7. Click Calculate. The results of the connection lengths will then display. The values 

of the connection lengths include:  

Results: 

Chainage - Distance from the point of connection of the sewer line along the direction 

of the sewer pipe to the downstream manhole. 

Offset - Perpendicular distance from the property connection to the sewer pipe. 

IO-Distance – Distance from the property connection along the direction of the sewer 

pipe to the downstream manhole. 

SO Nearest - House Connection perpendicular distance to the nearest cadastral 

boundary. 

SO Other - House Connection perpendicular distance to the next nearest cadastral 

boundary. 

Note: You can right-click on any measurement node and change the displayed measurement value 

or remeasure in Plan View or 3D View. 
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The results of the calculations are shown below. 

 

8. If satisfied with the results, click Apply to save the displayed house connection to 

the lines attributes. 

9. Then, click Close to finish. 
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ADAC Settings V5.01 or V4.2 

Use the ADAC Settings panel to enter appropriate header attributes for your project. The ADAC 

Settings panel is brought up with any header data already entered for the current project. The ADAC 

settings information is only entered once for a project. This requires only a small amount of 

information, consisting of ADAC project name, the asset owner and construction date, the coordinate 

system used and other optional attributes such as the surveyor and the engineer name.  

To open the ADAC Settings navigate to ANZ Toolbox > ADAC > ADAC Settings V5.01 or V4.2. The 

command window will display.  

1. Fill in the information that is required to be included in the ADAC XML. Click the 

Auto-Fill Settings button to start the process and then enter all remaining values. 

An example of setting information is shown below.  

2. Click the Auto-Fill ObjectID to automatically give all the attributes a unique ID 

value.  

Note: Every asset in ADAC has a unique identifier.  

3. Next if required, choose an As-Built Surface from your project, and click Update 

Elevations to update elevation values automatically for surface elevation and 

average depth on the below line objects. 

a. House Connection 

b. Pipe (non pressure) 

c. Storm Water Pipe 

4. Once satisfied with the information click OK. The settings will then save and the 

attributes will be updated on the data when you export the ADAC XML.  
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6.Validate and Export an ADAC XML from TBC 

After the project has been edited, the settings created, and the user is satisfied with the standard of 

the data the next step is to Validate the data against the Schema using the Validate ADAC 

command. ANZ Toolbox > ADAC > Validate ADAC 

 

Choose the version being used for this data set and select all the data on screen to be checked. Any 

errors that need attention will be shown in the message box and can then be resolved individually. 

Double click on an error line to highlight the object on screen that it is related too.  

Note: There may be some data that has had attribute fields left empty on purpose such as pavement 

layers and these will get flagged. If they are correct and are allowed to be set to nil in the schema 

you can highlight the lines and right click to display “set parent to nil” and this will set them 

correctly, so they are no longer considered to be an error. 

Any codes used that were in the “Supplementary” category will have the “Class” attribute 

automatically filled out after using the ADAC Setting command, but none of the other attributes will 

be checked as they are not part of the official schema. 

Once the data has been validated, export the data as an ADAC XML format which is compatible with 

GIS software and other packages.  

To export data:  

1. Start by selecting the points, lines and polygons to be included in the XML. Select 

the features in the plan view, project explorer or 3D view. Everything selected will 

be highlighted.  

2. Then navigate to Home > Data Exchange > Export or click the  icon in the quick 

access toolbar. Opening the export window.  
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3. In the export window click the Construction Tab then select either ADAC 

exporter (v4.2) or ADCA exporter (v5.01) from the list.  

4. Next, click the  icon. Choose a file location to save the exported xml and give 

it a name.  

5. Then click Export.  

Note: During the Export process the “Surface level” attribute will be updated from the point 

elevation for the following features. 

• Sewerage – Maintenance Holes (3x codes – Rec, Circ & Custom) 

• Stormwater – Pits (3x codes – Rec, Circ & Ext) 

• Water Supply – Maintenance Hole (2x codes – Rec & Circ) 

 

An exported file can be checked via the Validate ADAC command without needing to import it into 

TBC. 
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7.Importing ADAC XML into TBC 
 

TBC also allows the user to import ADAC XML files. This allows the user update XML files that have 

errors or bring in external data.  

1. First step to importing an XML file is to import the associated FXL, see page 6.  

2. Once the FXL file has been imported into TBC the next step is to import the XML 

file. Follow the same steps used to import the FXL to import the XML.  

Looking at an example, a comparison of the properties of a sewer pipe (non-pressure) can be made 

before the pipe was exported out of TBC as an xml and after the pipe has been imported as an xml.  

 

Comparing the two there is a noticeable difference in the attributes. Notice the ADAC 

Settings have been imported with the XML and are referenced in the attributes of the 

imported pipe data. Also notice the lot has been assigned a unique ADACId.  

 

 

Before exporting After importing as an XML 
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8.Annotating drawings with Attribute values 
 

It is possible to annotate your drawing with the required attribute values from your data using the 

“Annotate Objects” command in the ANZ Toolbox ribbon. (Example file available from 

anztoolbox@sitechcs.com) 

By creating a rule set you can quickly apply these to your whole data set and then go and manually 

edit the placement of text to suit your drawing layout. 

 

Once the text has been moved around to suit it is ready to plot. 

 

mailto:anztoolbox@sitechcs.com
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9.Code names and Features List 
 

Standard ADAC Schema 

The standard ADAC Schema FXL’s provided are found in “C:\Program Files\Sitech Construction 

Systems\ANZToolbox_***” 

• ADAC_TBC_V4.2.FXL 

• ADAC_TBC_V5.01.FXL 

Adding Supplementary features 

The supplementary category is for any additions to the ADAC schema, which allows users of ADAC to 

define any custom attribute not included in the published schema. This feature is designed to cover 

areas of interest and enable users to gather more data. Similarly, the implementation in TBC follows 

the same concept, meaning, as the user, you can add your own custom features. 

This means there's no limit on the number of Text, Integer, Date, etc., attributes you can add for 

each new attribute you create in the supplementary category. These can be point, polyline, or 

polygon features. The key is to ensure they are created under the “Supplementary” category. A easy 

way to do this is by duplicating an existing feature, then customizing it with any additional attributes 

that fit your specific needs. 

It's also worth noting that the “Class” attribute for a supplementary feature is inherently tied to the 

feature's name. This means if you have a separate 'class' attribute in your attributes list, it will be 

replaced during processing. 

An updated V5.01 FXL with Supplementary codes from Gold Coast City Council and Port of Brisbane, 

plus line styles and symbols is available. There is also a PDF version of the Code list available by 

emailing anztoolbox@sitechcs.com 

• TBC_ADAC_V5.01_SUPP.FXL 

Standard Line Control Codes used in ADAC FXL’s 

 

 

 

mailto:anztoolbox@sitechcs.com
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Appendix 
 

Below is a list of the Standard ADAC Codes and Features and the extra Supplementary codes and 

features from Gold Coast City Council and Port of Brisbane that are available in the 

TBC_ADAC_V5.01_SUPP.FXL file.  
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